OUR NETWORK: TiVo Community Explore3DTV My Open Router DVRplayground MediaSmart Home See all... About UsAdvertiseContact Us

 
Learn about scoring Forum's Raw Score: 1002300.0
January 21, 2011 07:53 PM

Categories: Televisions and Projectors

Rating (0 votes)
  • 1
  • 2
  • 3
  • 4
  • 5
Rate This!

Member Avatar

Klobersaurus

Member
Joined: 01/21/2011

Model: WD-65837

I inherited this tv and was excited to turn it on.  It, however, won't work.  The procedure goes as follows starting from plugging the tv in.

- I plug the tv in and there are no lights on.  The status light is blank.

- Turn tv on and the green light blinks for about 15-20 seconds.  Then it stays on, solid green.  During this blinking time, I hear a high pitch whirring sound that I assume is the color wheel. or some kind of fan.

- The tv screen displays no sign of functioning and there is no sound.  It won't respond to anything but the power button.  (When this is pressed, it successfully turns off. On and off can also be performed with the remote.)

- If I leave the tv for a couple minutes, it turns itself off and the status light remains on as a solid red.

I have read about the blinking green light of death, but this does not seem to fit that diagnosis exactly.  The tv sat idle for about 3 months at a temperature of about 60 degrees F before I picked it up and brought it home.  As far as I know, the tv worked fine before that 3 month period.

I know very little about DLP tv's, but I'm fairly confident I'd be able to repair the capacitors if it is in fact the Green light of death problem.

Any help at all on this issue would be greatly appreciated.  Thanks! 

Discussion:    Add a Comment | Comments 1-12 of 12 | Latest Comment

January 21, 2011 10:45 PM

evil said: What is the chassis number?
V41+

January 22, 2011 3:23 AM

Use the front panel buttons not the remote.Hold the Activity and Channel Down buttons at the same time for 5 seconds,this will activate the self diagnostics.You will get a series of blinks,one set then a pause then another set,write the number of blinks for each set and post them.

Click here--> http://www.tvrepairkits.com/xcart/home.php?partner=evilpea&bid=6 for all your electronic repair needs.

January 22, 2011 8:09 AM

evil said: Use the front panel buttons not the remote.Hold the Activity and Channel Down buttons at the same time for 5 seconds,this will activate the self diagnostics.You will get a series of blinks,one set then a pause then another set,write the number of blinks for each set and post them.

I do not seem to get two sets of blinks.  Instead, it blinks 6 times --> short pause --> another 6 blinks --> Long pause --> repeat.  There is a total of 60 green light blinks.

5 subsets of 12 which are then divided into 2 subsets of 6.

January 22, 2011 4:24 PM

Sorry I forgot to mention that this code will blink a total of 5 times...Only the first two are important.

66 - Lamp did not turn on at power on sequence = loose CJ4 connector
no lamp inserted = no lamp inserted
Disconnected cable between ballast & lamp = HV connection or lead wire to lamp
lamp-enable goes to pwb-MAIN but not ballast = lamp cartrige failure

Click here--> http://www.tvrepairkits.com/xcart/home.php?partner=evilpea&bid=6 for all your electronic repair needs.

January 22, 2011 4:30 PM

Im working on reformatting the manual into pdf format so I can up load it on to here for everyone.Are you willing to take the tv apart?

Click here--> http://www.tvrepairkits.com/xcart/home.php?partner=evilpea&bid=6 for all your electronic repair needs.

Answers Post January 22, 2011 8:17 PM

Sounds like you have a bad lamp or ballast,ive heard many people say that if you change the lamp you may as well go ahead and change the ballast because its not going to last long pushing the new lamp.

Click here--> http://www.tvrepairkits.com/xcart/home.php?partner=evilpea&bid=6 for all your electronic repair needs.

January 22, 2011 9:20 PM

evil said: Sounds like you have a bad lamp or ballast,ive heard many people say that if you change the lamp you may as well go ahead and change the ballast because its not going to last long pushing the new lamp.

Hey, thanks.  I've inspected the lamp to see if there is anything wrong with it, but I cannot tell.  I would expect to see the filament broken or some burn marks on the inside of the bulb, but these are not present.  Is there any way to tell if the lamp is bad?  It would be a shame to buy a new lamp for $100 just to find out it wasn't the problem.

January 22, 2011 9:53 PM updated: January 22, 2011 9:55 PM

http://www.techlore.com/forum/thread/15768/Samsung-DLP-lamp-ballast----HELP-/... This post says it all...Thats the problem you may have if you only replace one or the other it will work fine for a few months then bam the same thing happens agin and leaves you wondering more than when you started.

Click here--> http://www.tvrepairkits.com/xcart/home.php?partner=evilpea&bid=6 for all your electronic repair needs.

January 22, 2011 11:50 PM

Heres a link to the Service Manual in case you need it for any referances.The quality is not the best but.... http://www.techlore.com/download/31034/Mitsubishi-chassis-v41c-v41-v41-Servic... Let us know how the repair went.

Click here--> http://www.tvrepairkits.com/xcart/home.php?partner=evilpea&bid=6 for all your electronic repair needs.

October 25, 2013 9:48 AM

i have a mitsubishi wd 60735..no pic..changed the bulb..worked for awhile..has sound..turn tv on and then it shuts itself off..help?

October 25, 2013 9:51 AM

need help with my mitsubishi dlp wd 60735..no picture

View unverified member's comment - posted by rash

Discussion:    Add a Comment | Back to Top | Comments 1-12 of 12 | Latest Comment

Add Your Reply

(will not be displayed)

Email me when comments are added to this thread

 
 

Please log in or register to participate in this community!

Log In

Remember

Not a member? Sign up!

Did you forget your password?

You can also log in using OpenID.

close this window
close this window