OUR NETWORK:Dijit Community Explore3DTV My Open Router DVRplayground MediaSmart Home See all... About UsAdvertiseContact Us

 
Learn about scoring Forum's Raw Score: 2758440.0
January 11, 2010 10:22 AM

Categories: Televisions and Projectors

Rating (0 votes)
  • 1
  • 2
  • 3
  • 4
  • 5
Rate This!

Member Avatar

olivwa

Member
Joined: 01/11/2010

Hi- can you please help?  I've had my sony wega projection screen, model kp51ws520 5yrs.  Its blinking 10 times. I read your troubleshoot guide.  I want to change the q8014,q8013,r8051, and ic8005 on the D board.  Is this a easy fix? What do you recommend?  Whats the average cost to repair?  Thanking you kindly for your help!  Please keep your website open.  You guys are God sent.

Discussion:    Add a Comment | Comments 1-25 of 26 | Latest Comment | 1 2 Next »

March 23, 2010 9:35 AM

Having the exact same problem, OLIVWA. When I turn on the tv, I have audio but no video. Powers off after 5 to 10 seconds then shuts down. Standby blinks 10 times. I have done the display, channel, 5, volume minus, power but nothing comes up video wise. When it did the same thing 2 months ago, the display, channel etc worked but now to no avail. Sometimes, standby will blink 5 times but revert back to 10 blinks. Any answers?

May 15, 2010 5:21 PM

Hey kraus70. Just wandering if you found a solution to your problem. I am having this same problem as well almost down to the T!!! If you have fixed this or know something about it it would be nice to get some info from you on it and your progress. I would greatly appreciate this. Thanks

June 8, 2011 9:52 AM

Ditto the above issues to a 'T' on our TV (same model, everything!) Any assistance would be greatly appreciated.

June 8, 2011 3:35 PM

10 blinks means HV shutdown

? Q8014 or Q8013 have shorted replace
along with R8051 on D Board
? IC8005 is damaged (D Board)

Click here--> http://www.tvrepairkits.com/xcart/home.php?partner=evilpea&bid=6 for all your electronic repair needs.

July 18, 2011 1:02 PM

Has anyone had any luck resolving the 10 blink error code for KP51WS520? I had to resolve the 9 blink error code of this model several years ago with a new G Board and thought I had the same problem again. I replaced the D6301 diode, but noticed that I am getting 10 blinks (may have always been 10 blinks and I just missed it assuming it was a repeat of an original problem).

July 18, 2011 9:28 PM

Have you tried checking the transistors or resistor I mentioned above?

Click here--> http://www.tvrepairkits.com/xcart/home.php?partner=evilpea&bid=6 for all your electronic repair needs.

January 17, 2012 2:58 PM

I also had the 10 blink code on my kp-51ws520. I replaced the (4) parts that were suggested. It worked great for one day then 10 blinks again. I used Sony parts. Any suggestions for what to try next? Thanks in advance!

January 17, 2012 3:39 PM

I know on some of there other models when they get a HV shutdown it's because of the distribution block/ focus block you could try marking the nobs on it so you can return them back to their original posistion and adjust them by rocking all of the nobs back and forth a few times and return them back to where they were. http://www.techlore.com/article/26744/G2-Adjustment-and-Electrical-Focus-Proc... other than that you may have a bad LOPT/fly back transformer and a board replacement may be necessary.

Click here--> http://www.tvrepairkits.com/xcart/home.php?partner=evilpea&bid=6 for all your electronic repair needs.

January 17, 2012 4:49 PM

Thanks for the advice! Can you give me an approximate location of this focus block on my model (kp-51ws520)?

January 17, 2012 5:08 PM

Most are at the front of the tv on the bottom half.

Click here--> http://www.tvrepairkits.com/xcart/home.php?partner=evilpea&bid=6 for all your electronic repair needs.

January 18, 2012 12:34 AM

Well, I adjusted and returned the focus controls as you suggested and no dice. Thanks for the helpful advice but I guess it is time to call a pro to come look at it.

January 18, 2012 1:08 AM

Let us know how that goes and what he finds.

Click here--> http://www.tvrepairkits.com/xcart/home.php?partner=evilpea&bid=6 for all your electronic repair needs.

January 25, 2012 10:24 AM

Well dam, I just called the tv repair guy. He will be here tomorow at 2. I'm having the exact same problem. On, no pic. Cuts off 5 sec. Blinks 10. Unpluged 30 secs blinks 5. Display 5 vol down power does nothing. Tv repair guy said power up , not down. Still nothing. We will all know tomorow. I'll post the results.

July 17, 2012 8:05 AM

Brice did he ever fix it same problem here have tv repairman looking at mine, ordered all parts from above and going to try them. IC and transistors.

July 18, 2012 2:48 AM

Char what IC are you talking about? No sense in replacing parts if they can be tested.

Click here--> http://www.tvrepairkits.com/xcart/home.php?partner=evilpea&bid=6 for all your electronic repair needs.

July 18, 2012 8:59 AM

Have you tried any of the above suggestions, in particular the HV distribution block knobs? If you are getting an attempted turn on then checking ic8005 may be possible it is only 3 pins and one is ground.

Click here--> http://www.tvrepairkits.com/xcart/home.php?partner=evilpea&bid=6 for all your electronic repair needs.

September 23, 2012 12:28 PM

Any body find the way to fix the sound but no pic 10 blink problem ... I hav the same tv and the same problem .need help plz . Ben following the posts and no one said if any thing worked.

September 23, 2012 5:24 PM

So wat tha tv repair guy say .bnice

September 23, 2012 11:03 PM

Have you tried adjusting the knobs on the HV block?

Click here--> http://www.tvrepairkits.com/xcart/home.php?partner=evilpea&bid=6 for all your electronic repair needs.

September 24, 2012 4:53 AM

Sony liquid crystal display projection televisions use high-intensity lamps to project high-definition images onto their screens. Over time, these lamps begin to degrade, indicating that it is time for a replacement. Observe common on-screen and display-light indicators to troubleshoot whether the lamp is indeed on its way out or to decide if you have a different, undiagnosed issue with the set.

September 24, 2012 6:50 AM

Dmdcjas,
A 10 blink error code on this one is an indication of a problem on the D board. There are two main IC's that would need to be changed. These are IC6400 and IC8002 they are both part number MCZ3001DB and you can get them many places online, I recommend http://www.bdent.com/ . Basically it is straight forward, open the set up, get the D board out, unsolder the old chips, install the new ones, solder them in and put the board back in.

September 24, 2012 3:10 PM

So it's not tha diodes on tha g board rite ? Yes evil I tried tha knobs. If I get 10 blinks its tha d board?

September 24, 2012 3:11 PM

Dmdcjas, I fixed the 10 blink error myself by fixing these 2 chips.

September 24, 2012 3:17 PM

Thanks ,I will try this n let u no if it worked , u guys r god sent.

September 26, 2012 11:58 PM

Hello Friends
I am having 8 Years Old SONY Projection TV KP51WS510 which had convergence problem some 2 Years back and was able to fix it through this helpful forum. Now again I need help for different problem .i.e The Picture is very dark and the colors are dark with distortion. The Menu letters are OK and straight with perfect color ( Green). The Letter are not Bowing or bending.
Can somebody help me whether this is again a convergence Problem or something else with some tips to fix it. Thanks in advance.

Discussion:    Add a Comment | Back to Top | Comments 1-25 of 26 | Latest Comment | 1 2 Next »

Add Your Reply

(will not be displayed)

Email me when comments are added to this thread

 
 

Please log in or register to participate in this community!

Log In

Remember

Not a member? Sign up!

Did you forget your password?

You can also log in using OpenID.

close this window
close this window