OUR NETWORK: Dijit Community Explore3DTV My Open Router DVRplayground MediaSmart Home See all... About UsAdvertiseContact Us

 
Learn about scoring Forum's Raw Score: 1793420.0
February 22, 2009 01:44 PM

Categories: Televisions and Projectors

Rating (0 votes)
  • 1
  • 2
  • 3
  • 4
  • 5
Rate This!

Member Avatar

Callmecannonball

Member
Joined: 02/22/2009

Hi,    I have and LG 37" lcd about 2.5 yrs old.   4 Days ago it started flashing the connecting message ans then the whole screen started flashing from black to white and then it just went to a black screen, not off but black.   During this time I have no sound, no menu, no response at all accept that the led flashes when a remote button is pushed and I am to shut it off with the remote. It stays this way for at least 30 minutes.   When I turn it back the led flashes 14 times then comes on steady and sometimes the tv works for about 5 minutes or so.   I have disconnected the verizon dvr and tested with just the dvd with the same results.     Any help on this issue would be appreciated.                    

I was told that it was probably the main board. I feel comfortable replacing that but  I don't know if the board would wavt to be flashed with firmware after install. Does anybody know?

Thanks for any help in advance !

Danny L.

"If I claim to be a wise man it surely means that I do not know, but I hope that someday I could be as great as my DOG already thinks I am"

Discussion:    Add a Comment | Comments 1-11 of 11 | Latest Comment

February 22, 2009 7:22 PM

I also verified power supply with meter.

Danny L.

"If I claim to be a wise man it surely means that I do not know, but I hope that someday I could be as great as my DOG already thinks I am"

February 22, 2009 10:03 PM

what version firmware do you have now?
could you have wrong version or incomplete firmware flash?
there is a phone number at the bottom of this page for firmware support


http://us.lgservice.com/vchip_html/V-chip_upgrade_for_your_set.html

Mitsubishi WS-55513, Philips 55pp9352/17

February 25, 2009 11:36 PM

Alnp, Thanks for the info.
I don't know what version I have as the tv has failed. I believe the problem is the main board and plan on replacing it. But it is just based on a swag. At 300+ bucks I was hoping somebody had a better idea. Although I have pc and electronics experience, I have not replaced a tv main board and don't know if firmware is already installed. Unfortunatly my tv is listed in the last step of the firmware update and I will have to call LG if the upgrade is needed.

Danny L.

"If I claim to be a wise man it surely means that I do not know, but I hope that someday I could be as great as my DOG already thinks I am"

February 26, 2009 1:50 PM

A replacement mainboard will have some version of firmware installed.
Several models of 32 and 37 LG and Zenith use the LA51D chassis.
It might be cheaper buying a whole tv with shattered screen, for parts.

You have verified the power supply.
A bad inverter board or lamps should have black screen with sound.

Unplug and reseat all wiring harness connectors.
Try changing resolution down to 480i or 480p.
Try using a different input.
If the set runs at low resolution check the power supply capacitors further.

Mitsubishi WS-55513, Philips 55pp9352/17

February 27, 2009 9:13 PM

Do you have a line a shattered LG 37LC2D-UD or campatable?

Danny L.

"If I claim to be a wise man it surely means that I do not know, but I hope that someday I could be as great as my DOG already thinks I am"

February 28, 2009 10:10 PM

Sorry, I do not know of any for sale. If you search by the mainboard part number you might turn one up, or find reference to other sets that used the same board.

Mitsubishi WS-55513, Philips 55pp9352/17

June 10, 2009 2:37 PM

Hi,

I am having an issue with my LG 37 as well, same age. My remote will not work the unit, or the cable remote. I also don't get the led flicker when pressing a remote button. I replaced the IR sensor on the tv, same problem.

Something odd, when I press the channel up button on the side of the tv, it turns the unit on. Very odd.

Any ideas?

Thanks in advance,
Jeff

July 29, 2009 7:50 PM

Jeff

How did you replace the IR Sensor? I think my ir sensor has gone bad. Similar issue. Have you put fresh batteries in the remote? Again, how did you replace the IR sensor?

Mike

August 27, 2011 9:33 PM

I have a 2006 Lg 37LC2D-UD and the past two days the tv works when it wants to, the picture on the tv will show clear and fine for about 15 minutes or so and then the screen goes to a gray screen, no sound or picture. I cant get the tv menu to pull up and from the research I have done it points to the capacitors. Can anyone help point me in the right direction please and thank you.

View unverified member's comment - posted by CHESTERALI

January 7, 2012 3:12 PM

I had the same problem as the first post, and ordered, received and have replaced the main board. However, the TV is wonky in a different way. Initially, I could get a menu and static and audio from the CD player. Once installed on the shelf I cannot, the TV turns own, shows channel 4 and static with sound but then flashes off, and on, and off and on over and over like it is cycling though channels. I cannot get a menu. Do I have a firmware problem, and if so, how to troubleshoot?

Discussion:    Add a Comment | Back to Top | Comments 1-11 of 11 | Latest Comment

Add Your Reply

(will not be displayed)

Email me when comments are added to this thread

 
 

Please log in or register to participate in this community!

Log In

Remember

Not a member? Sign up!

Did you forget your password?

You can also log in using OpenID.

close this window
close this window