OUR NETWORK: Dijit Community Explore3DTV My Open Router DVRplayground MediaSmart Home See all... About UsAdvertiseContact Us

 
Learn about scoring Forum's Raw Score: 3824340.0
November 8, 2007 10:38 PM

Categories: Televisions and Projectors

Rating (0 votes)
  • 1
  • 2
  • 3
  • 4
  • 5
Rate This!

Member Avatar

David1234

Member
Joined: 11/08/2007

Looking for some help. I have a toshiba 53hx71 that worked perfect the night before, but when I got up to watch the news the very next morning all I go was a flashing red light. Any advice. Could it be the power supply and if sow what should I look for to be the problem.

Thanks

David E.

Discussion:    Comments 1-25 of 55 | Latest Comment | 1 2 3 Next »

December 28, 2007 11:27 PM

david  open the the back of your tv look for  p807 on the power supply  unplug it  and plug your  tv to the wall outlet  and hit the power bottom if the tv come on that mean you convergence problem replace both STK's 392-110

January 7, 2008 1:58 AM

dave,

i have the same problem.  i noticed this before and i plugged and unplugged the power cord and it worked.  however this time, it didn't work.  the second time it happened was when my son was turning it on and off constantly...i guess that had what happened the first time. 

funny how it happened a year after my extended warranty expired.   

kenzo, thanks for the advice, i'll let you know if it works after i follow your advice. 

January 7, 2008 9:15 PM

Kenzo said: david  open the the back of your tv look for  p807 on the power supply  unplug it  and plug your  tv to the wall outlet  and hit the power bottom if the tv come on that mean you convergence problem replace both STK's 392-110

Kenzo,

i can't locate p897 nor the STK 392-110 IC.  Can you take a picture if you don't mind?

thanks,

james

January 7, 2008 11:19 PM

basic555 said:
Kenzo said: david  open the the back of your tv look for  p807 on the power supply  unplug it  and plug your  tv to the wall outlet  and hit the power bottom if the tv come on that mean you convergence problem replace both STK's 392-110
Kenzo, i can't locate p897 nor the STK 392-110 IC.  Can you take a picture if you don't mind? thanks, james
will p807 on the power supply board  and the STK's 392-110 is on the big aluminum heatsink is a metal

January 7, 2008 11:44 PM

basic555 can you check the fuses F850,F851,F852 if blown replace and you bad connection also.Underneth the board Do you have knowledge to repair televisions goodluck

January 8, 2008 9:38 AM

Very common problem. There is a Toshiba service bulletin out on this . Look for F860, if it is blown, do not replace it till you pull out the chassis and look in the main power supply for the two large capacitors, C809 and C810. They may have bad connections on the negative connections due to the printed circuit board eyelet being left out of the set. I have repaired many of these sets and once after another tech wanted to charge the customer 600 bucks! Just be very careful when working on this TV set. Good Luck

"Those who do not know their opponent's arguments, do not completely understand their own".**For complete TV repair kits including parts goto www.TvRepairKits.com

February 2, 2008 4:48 PM

Kenzo said:
basic555 said:
Kenzo said: david  open the the back of your tv look for  p807 on the power supply  unplug it  and plug your  tv to the wall outlet  and hit the power bottom if the tv come on that mean you convergence problem replace both STK's 392-110
Kenzo, i can't locate p897 nor the STK 392-110 IC.  Can you take a picture if you don't mind? thanks, james
will p807 on the power supply board  and the STK's 392-110 is on the big aluminum heatsink is a metal
I just had this issue arise this past week.  I have followed you instructions and found the STKs, but I can't discern where the P807 plug is located.  I have traced all of the wiring to their locations on the power supply board but none of them is labeled P807.  Can you head me in the right direction?

October 3, 2008 2:25 AM

can capacitator stk 392-110 be tested to see if blown?

October 3, 2008 2:29 AM

please advise,shiden type 2 thankyou.

January 3, 2009 4:13 PM

Larry Dillon THANK YOU VERY MUCH: My blinking red light and blown F850 + F852 were solved by simply resoldering the C809 and C810. PRAISE THE LORD. Time invested in researching and talking to local Toshiba shops was 12 hours. Toshiba shops were familiar with what I discussed but also said convergence ICs must also be replaced with an estimated in house repair cost of $500. No thank you. Satisfaction with fixing it myself with your help, PRICELESS!

I wish I had been able to find the Toshiba Service Bulletin. Someone posted a link but without the Toshiba tech login info I could not access it. If you have it would you send it to me. Thanks again and Happy New Year.

January 3, 2009 7:08 PM

yes a very common problem with the Toshiba, I will attempt to send the bulliten I posted several months ago, but whatever does not really matter as long as it halp you do a FIY "Fix it Yourswlf" or shall I say a DIY to save big bucks, abd these days unlessm your a CEO and still gettting a few million dollar bonuds for running the corpoation to the limits ( THE GROUND!!!!_) The iorney is you pid FOR IT!I need an e- mail to send you anything, I am good but NOT a fortune teller.

"Those who do not know their opponent's arguments, do not completely understand their own".**For complete TV repair kits including parts goto www.TvRepairKits.com

January 4, 2009 8:21 PM

You can email to trt-junk@comcast.net if you have it...
for future reference. Thanks Larry.

January 4, 2009 8:32 PM

Larry, you really know your stuff. I like that. I have the Toshiba 57H81 factory service manual and I want to tune up the convergence beyond the user level convergence. Is there a link on this forum that walks you through any tricks of the trade or perhaps a youtube video of doing. I paid a professional five years ago to both adjust the color and convergence. Thanks again. Tom from Indianapolis (NOT A CEO but an entrepreneur.)

November 27, 2009 4:00 PM

hey kenzo are you out there?????? I am working on my toshiba 53hx71 and have the power light blinking and found the 3 pico fuses blown..850,851,852 and have searched for that bad connection and cant seem to locate. i have re-installed the board once after changing 3 fuses and both the 392-110 and all 3 fuses blew again do you have any insite?????

November 28, 2009 6:13 AM

Where did you get the ic's from. are they the original stk ic's?The best advice I can tell you at this point is to go to tvrepairkits.com and order the complete convergence kit for your model of TV set, no need to search and order multiple parts from different sources and pay multiple shipping fees! The kit comes with original Sanyo STK IC'S , not those cheap aftermarket or china made IC'S full pictorial directions, the thermal paste, resistors, the correct Pico fuses, AND free live on-Line tech assistance in case you run into a problem with the repair. They ship out 2 to 3 day Priority mail, the next day in most cases GOOD LUCK!!!

"Those who do not know their opponent's arguments, do not completely understand their own".**For complete TV repair kits including parts goto www.TvRepairKits.com

November 28, 2009 8:28 AM

hey larry how are you? I want to say that i got these parts from tritronics and do believe they are sanyo parts..do you relly think that it con be a bad stk part that i have put in..i did not think that the stks were the main problem when the pico fuses were found to be blown...i acually had them here in stock on my shelf and had first relaced them...i still had the blinking light..i removed the board again and checked farther to find f850,851 blown . i then replaced them and tried again...still no good. i pulled the board and checked the fuses and this time 850 851 and 852 were blown. i have checked all me diodes and looked at most of the transistors with a meter and dont find anything apperent (shorted) i also inspected the board for bad connections on the bottom and may have found 1 or two but still nothing. i have checked all the resistors in the convergance section and all appear to be good also. i checked the two caps c810 and c809 connections and they are also good.you still think i should try 2 new stk392-110 or do you have any other thoughts..

December 12, 2009 2:21 AM

Kenzo & Larry: Thank you very much. I just fix my Toshiba 53HX71 by replacing the dead ICs stk392-110

December 12, 2009 9:15 AM

Well i Re-ordered 2 more of the stk392-110 and made sure to order the sanyo originalls. Went ahead put the on in and tried the board again. No go. took the board out and checked the pico fuses f850 and f851 both were blown again. Any ideas anyone. HELP

December 15, 2009 2:49 PM

Most likely the C809 / C810 solder connection as described in this thread. I fixed mine by not only resoldering but adding redundant wires along the paths. Was never able to find the Toshiba bulletin (w/o tech login) but Toshiba told me about it. Wish someone would post the Toshiba bulletin. I was told that a manufacturing defect meant that each of those capacitors was missing some reinforcement of some sort at the solder connections and over time they cause the problem. I fixed this once by resoldering but it only lasted several months. I resoldered again adding the wires and it has been good since.

December 15, 2009 2:52 PM

THREE DOT PROBLEM (PERFECT TRIANGLE) in center of screen. After the second time I resoldered by C809 C810 capacitors I ended up with three dots in a triangle in the center of my screen. Never replaced convergence chips.

Has anyone ever had this three dot issue after fixing the blinking red light problem? Thanks.

December 27, 2009 6:59 PM

I also replaced the convergence chips from tvrepairkits.com but 850 and 851 blew again immediately on power up. We have checked C809/810 and they seem to be ok, F860 has never blown it has always been a combination of 850/851/852. 853 has never blown. Any other ideas on possible things to check. I'm running out of time, wife wants a new tv ;-)

December 27, 2009 10:04 PM

Even though C809/810 seemed to check out with the meter, tried Tommy's trick of adding redundant wires and now have my picture back. Am hoping the fix sticks and lasts a while! Thanks for all the advice in this thread.

December 27, 2009 11:57 PM

most of the time I have just re soldered the big power supply caps but you need to remove the old solder and scrap off the paint all the way around both of the caps connections then resolder really good.

"Those who do not know their opponent's arguments, do not completely understand their own".**For complete TV repair kits including parts goto www.TvRepairKits.com

December 29, 2009 9:46 AM

Hey guys i just finished cleaning all the solder from C809 and C810 and re-soldeed along with adding the wires from point to point on these caps. Pluged the board back into the set and still i blew F850 / F851. Does anyone have the print for this power supply board or dose anyone have any other thoughts..I am running out of ideas?????????

December 30, 2009 3:55 AM

make sure you check all of the caps, diodes, and resistors for open or shorted conditions. you can also try putting a 75 to a 100 watt light bulb across the main fuse and if the light lights up bright when you turn on the set most likely you have a bad power supply or maybe the horizontal output transistor is shorted good luck!!!!!
Larry Dillon

"Those who do not know their opponent's arguments, do not completely understand their own".**For complete TV repair kits including parts goto www.TvRepairKits.com

Discussion:    Back to Top | Comments 1-25 of 55 | Latest Comment | 1 2 3 Next »

Thread is locked, no more posts may be added.

 
 

Please log in or register to participate in this community!

Log In

Remember

Not a member? Sign up!

Did you forget your password?

You can also log in using OpenID.

close this window
close this window