OUR NETWORK:Dijit Community Explore3DTV My Open Router DVRplayground MediaSmart Home See all... About UsAdvertiseContact Us

 
Learn about scoring Forum's Raw Score: 1.11343E7
November 19, 2006 11:23 AM

Categories: Televisions and Projectors

Rating (0 votes)
  • 1
  • 2
  • 3
  • 4
  • 5
Rate This!

Member Avatar

Dale Bowers

Member
Joined: 11/19/2006

I recently had to replace the lamp in my Samsung DLP TV after 3 years.  Worked great for 1 month.  Today while watching TV the screen went blank.  The lamp no longer lights when I turn on the TV.  Does anyone know how I can tell if I got a defective lamp or has the ballast gone bad? 

Discussion:    Comments 26-50 of 126 | Latest Comment | « Previous 1 2 3 4 5 6 Next »

September 8, 2009 9:37 PM

My Samsung DLP has not lost the picture, but it's growing darker. Is that the lamp or can someone tell me what else it might be?

September 8, 2009 11:34 PM

That is a hard call until you replace the lamp as it very well could be, and unfortunately there really is no other way to test it but there is a very expensive lamp tester some authorized repair shops may have but most shops do not buy that equipment the cheap[est and most reliable way to test this bad lamp is with a new and/or a direct replacement lamp!!
Larry Dillon, Good Luck!!!!!

"Those who do not know their opponent's arguments, do not completely understand their own".**For complete TV repair kits including parts goto www.TvRepairKits.com

October 6, 2009 8:10 PM

I have a 61" samsung dlp, and my tv shuts off for no reason the lamp light starts blinking then i turn it right back on and then it makes a weird noise and turns back on. weird but this happens quite a bit. Any advice??

October 24, 2009 6:40 PM

josh, i think it may be your color wheel. only 2 moving parts in the tv. fans and color wheels. if that weird noise is a grinding/screeching that becomes low and then loud at times, its definitely the color wheel.

October 29, 2009 1:26 PM

I have a Samsung HLS6167 DLP. TV comes a few seconds the picture goes out (lamp turns off). The sound remains for another few seconds and system shuts down with all 3 lights on front flashing. I have replaced the lamp. I replaced the ballast and the TV worked for a few days the blew a Capacitor on the new ballast and replaced that cap twice. The Cap seems to be fine right now but I do not know why the cap kept blowing possible power supply. Can anyone help with some test or what to examine.

View unverified member's comment - posted by halle

View unverified member's comment - posted by Michael C.

December 3, 2009 2:05 AM

I also have a samsung DLP wich shuts off half hour after starting then every 2 to three minutes after. Have moved tv out from wall 2 ft, put fan behind, cleaned out tv with compressed air and makes no diff, have even bypassed blue switch in back where globe is and still no diff. Surly by now someone knows what is going on. Please help Regards Ian

December 3, 2009 3:10 AM

probably bad lamp even if it is new I have had several new bad lamps in the past, just send it back and tell them it is defective, or perhaps bad capacitors on the power supply board. or in the lamp ballast.Good Luck.
Larry Dillon.

"Those who do not know their opponent's arguments, do not completely understand their own".**For complete TV repair kits including parts goto www.TvRepairKits.com

December 3, 2009 9:54 PM

I have a Samsung DLP model HLR-4667W, just replaced the lamp and it appears the unit has blown the new lamp. The wire on the new lamp is broken, confirmed it was ok out of the box. The original Lamp code was BP96-00823A (O), The vendor I purchased the new lamp from shipped me BP96-01073A. Some forums say when you upgrade to the newer model lamp you need to replace the ballast. I hear a clicking noise in the back of the unit. When I Power on the unit the LAMP LED blinks for sometime then all three LEDs blink. The unit will not turn off I had to unplug it. Before buying another lamp and a ballast if they are still available how can I determine it the ballast and not the power supply is the problem, or how can I determine the problem before investing in another lamp? I'm not able to find a parts list or schematics on Samsung's site.

December 3, 2009 11:12 PM

i went to the http://www.samsungparts.com/search/search.asp and pasted in HLR4667W

and they have a lot of parts for your dlp

December 5, 2009 8:56 AM

I have a Samsung DLP HL-S4676S and it's always had an issue with how long it takes to turn back on after turning it off. Prior to replacing the bulb it took approx 10min and now it takes 15-20min. It's very annoying and tends to make us leave the TV on all day instead of turning it off just in case someone comes in the room and wants to watch something which never seems to fail once it's turned off. They, of course, want to throw their shoe through it calling it every name in the book. Leaving it on, of course, just burns through the bulb life. Anyone else have this problem ? Anything that can be done about it ?

December 7, 2009 2:57 PM

It looks like I have a shattered Color Wheel, bad Ballast and lamp. What would casue all to fail at the same time? Main Power supply? Any thoughts as if it's worth the investment or buy new?

Thanks

December 19, 2009 8:22 PM

I removed Lamp and Ballast cleaned dust from every thing put back together still no good, picture goes black after 30 min but lamp is still on, any suggestions what it could be
Ian

December 21, 2009 7:37 PM

I have a Samsung HLT5075sx and recently it had problems turning on it would go thru it's power on cycle 3x before revealing its 3 flashing dots of horror I noticed a clicking/humming sound. I want to fix it because I love this tv! It's actually only 2 years old and I've never had a problem with it since. Any ideas? I don't want to throw money away on purchasing parts I might not need.

December 22, 2009 11:03 AM

I have a samsung also. About two weeks ago now, it started to make a buzzing sound and the picture flickers. Then it straightens up and runs for a few before it does it again.So it is intermitent and is always hard at a cold start up. 30-40 minutes. Any ideas?

December 23, 2009 2:38 PM

newele,

sounds like the color wheel.

I am having a problem with no picture, 3 blinking led's, new bulb. Is there a way to check if the ballast is bad?

December 25, 2009 7:52 PM

So, my problem is this: blue power ring is on, no picture. Lamp LED keeps blinking. But the bulb is shining bright, color wheel is spinning. I can't turn it off unless I unplug it. When I plug it back in, I sometimes hear a whining noise (not grinding). I'm not sure which is the ballast or capacitor. If the bulb is shining, does that mean that works? Also, something does glow when I plug the power cord in, seems like that's making the whining noise. Dont' know what part that is.
Model# HL56A650C1FXZA
It's only 14 months old, of course, out of warranty.

Thanks!

December 27, 2009 9:45 AM

RHT,
sorry, I don't know that much about these tv's. I do know that there is another site, I would surf the archives, there is alot of information in there. You may be able to access info there. ecoustics.

December 27, 2009 9:47 AM

raguusauce said: So, my problem is this: blue power ring is on, no picture. Lamp LED keeps blinking. But the bulb is shining bright, color wheel is spinning. I can't turn it off unless I unplug it. When I plug it back in, I sometimes hear a whining noise (not grinding). I'm not sure which is the ballast or capacitor. If the bulb is shining, does that mean that works? Also, something does glow when I plug the power cord in, seems like that's making the whining noise. Dont' know what part that is. Model# HL56A650C1FXZA It's only 14 months old, of course, out of warranty. Thanks!
From what I've read in different forums, the whining is the ballast. try the same site I recommended for RHT.

February 3, 2010 11:26 AM

I've got a samsung modle hlp 5063 with no sound and no picture. I've replaced the lamp and still nothing nothing comming through the speakers only the quiet sound of the fan running. I can hear the ballast I think trying to fire up the lamp then it stops and shuts down. The power button in front flashes Lamp,Timer and Standby/Temp. I've been testing without any cable hooked up, I just have the tv on my dining room table and plugged into the wall. little help!

February 3, 2010 12:22 PM

You might have a bad power board or blown caps on it there is a download of the service manual for this set in the technicians corner go to the home page then the resources tab then technicians corner, then scroll down.
Larry D.

"Those who do not know their opponent's arguments, do not completely understand their own".**For complete TV repair kits including parts goto www.TvRepairKits.com

February 3, 2010 2:44 PM

Larry Dillon said: You might have a bad power board or blown caps on it there is a download of the service manual for this set in the technicians corner go to the home page then the resources tab then technicians corner, then scroll down. Larry D.
Well I took the thing apart again and was checking the color wheel and one of those little filiments fell off but not all the way just hung ther kinda loose. I was ready to throw in the towel so I put everything back together kept the back open and put my cordless drill proping that little blue sensor thing and one last time plugged it back in, nothing but then wiggled the ballast plug and the lamp came on in all it's glory! Only thing now was a loud noise from inside my guess an off balanced color wheel because of that little filiment hanging off. I pushed it some more and hooked up the cable box and the tv wasw on! Volume and picture! So definitly check that little plug that goes into the ballast. Maybe it's good to take stuff apart because it gets the dust off a little I'm not all that sure but it works now. Oh I need a new color wheel.

February 10, 2010 8:09 PM

when you turn my tv on then after about a minute later if that shuts off and makes a little buzzing noise for 2 or three seconds then turns itself back on and does it all over agian and agian. What could this be?

February 11, 2010 8:58 AM

56 Inch Samsung DLP said: when you turn my tv on then after about a minute later if that shuts off and makes a little buzzing noise for 2 or three seconds then turns itself back on and does it all over agian and agian. What could this be?

Like I said, I'm not an expert. I just hit the internet and started surfing. I did get my 42" sammy fixed. My got to that point, before I finally said enough is enough. When I pulled my colorwheel it was so hard to turn, pretty much completely gone. I finally, by searching found the one I needed.I finally got the new one in, with all of the manual and service adjustments and she runs like a dream. It wasn't as much of a job as I thought, but if you are doing it solo, can be a little intimidating. I found some info at jangro,ecoustics,but rarely an answer to my questions. All I di is type exactly what I wanted to know into my search engine and went to one after the other website. between exploring archives and new threads was able to piece it together. As I have said love my sammy,it has one of the best pictures. I really hope someone else will pipe up and help, to let you know if it could be more.

Discussion:    Back to Top | Comments 26-50 of 126 | Latest Comment | « Previous 1 2 3 4 5 6 Next »

Thread is locked, no more posts may be added.

 
 

Please log in or register to participate in this community!

Log In

Remember

Not a member? Sign up!

Did you forget your password?

You can also log in using OpenID.

close this window
close this window